How to resolve when you have rpmdb: unable to initialize mutex on FC4.

My server has error about rpmdb , I think this problem happens from my OS chooses library from kernel invalid. So I can solve this problem by set LD_ASSUME_KERNEL parameter like kernel version of OS.

# rpm -q xorg-x11
rpmdb: unable to initialize mutex: Function not implemented
rpmdb: /var/lib/rpm/__db.001: unable to initialize environment lock: Function not implemented
error: db4 error(38) from dbenv->open: Function not implemented
error: cannot open Packages index using db3 – Function not implemented (38)
error: cannot open Packages database in /var/lib/rpm
package xorg-x11 is not installed

Solve :

# export LD_ASSUME_KERNEL=2.6.11

Thanks : http://www.norgesinternettforum.no/archive/index.php?t-957.html

Comments

comments